Failure to boot Industry scenario on UP2 Atom x7-E3950.


Andrew Back
 

Hello,

Hardware is UP Squared P/N: UPS-APLX7-A20-0464 fitted with a 240GB mSATA
drive.

Followed the getting started guide at:

https://projectacrn.github.io/latest/getting-started/rt_industry_ubuntu.html

Installing the UOS to the SATA drive and SOS to the 64GB eMMC. ACRN
built with:

make all BOARD_FILE=misc/vm_configs/xmls/board-xmls/apl-up2.xml
SCENARIO_FILE=misc/vm_configs/xmls/config-xmls/apl-up2/industry.xml
RELEASE=0

Proceeded to build and install the kernel, and update Grub. Upon
rebooting "loading ACRN..." is printed out and there is a pause for a
few seconds, following which the system reboots. No other output at all.

I saw the note in the FAQ regarding memory and it looks as though the
default configuration for both CONFIG_PLATFORM_RAM_SIZE and
CONFIG_SOS_RAM_SIZE is 16GB, which seems odd, since AFAICT there is no
UP2 board available with more than 8GB fitted. In any case, I followed
the instructions at:

https://projectacrn.github.io/latest/faq.html#how-do-i-configure-acrn-s-memory-size

Setting the aforementioned parameters both to 4GB and reducing
CONFIG_UOS_RAM_SIZE to 1GB. Then rebuilt with 'make all RELEASE=0'
(specifying the XMLs this time resulted in error) and installed ACRN
again. However, this didn't seem to make any difference. Though I saw
after build that there was a .config file in build/hypervisor/ which had
the default higher RAM values configured, instead of those which I'd set
in hypervisor/build/.config. See the attached. Is the custom config
somehow being ignored? Maybe this is not the main issue even if so...

My guess is that ACRN is not being loaded at all / the build is very
broken, else I would expect this to at least print something out. Also
wondered if using a serial console would help in debugging? Wasn't sure
if this could provide greater insight into early boot failures.

Let me know if this looks like it may be an actual bug and I should log
this on the issue tracker. At this point however I'm suspecting user
error :o)

Regards,

Andrew

--
Andrew Back
http://abopen.com


Liu, Fuzhong
 

Hi Andrew
Could you please try multiboot instead of multiboot2?
multiboot2 /boot/acrn/acrn.bin -----> multiboot --quirk-modules-after-kernel /boot/acrn/acrn.32.out
If the issue is still there, please help to raise git issue and upload serial port log of ACRN.

Thanks!

BR.
Fuzhong

-----Original Message-----
From: acrn-users@lists.projectacrn.org <acrn-users@lists.projectacrn.org> On Behalf Of Andrew Back
Sent: Monday, December 28, 2020 8:15 PM
To: acrn-users@lists.projectacrn.org
Subject: [acrn-users] Failure to boot Industry scenario on UP2 Atom x7-E3950.

Hello,

Hardware is UP Squared P/N: UPS-APLX7-A20-0464 fitted with a 240GB mSATA drive.

Followed the getting started guide at:

https://projectacrn.github.io/latest/getting-started/rt_industry_ubuntu.html

Installing the UOS to the SATA drive and SOS to the 64GB eMMC. ACRN built with:

make all BOARD_FILE=misc/vm_configs/xmls/board-xmls/apl-up2.xml
SCENARIO_FILE=misc/vm_configs/xmls/config-xmls/apl-up2/industry.xml
RELEASE=0

Proceeded to build and install the kernel, and update Grub. Upon rebooting "loading ACRN..." is printed out and there is a pause for a few seconds, following which the system reboots. No other output at all.

I saw the note in the FAQ regarding memory and it looks as though the default configuration for both CONFIG_PLATFORM_RAM_SIZE and CONFIG_SOS_RAM_SIZE is 16GB, which seems odd, since AFAICT there is no
UP2 board available with more than 8GB fitted. In any case, I followed the instructions at:

https://projectacrn.github.io/latest/faq.html#how-do-i-configure-acrn-s-memory-size

Setting the aforementioned parameters both to 4GB and reducing CONFIG_UOS_RAM_SIZE to 1GB. Then rebuilt with 'make all RELEASE=0'
(specifying the XMLs this time resulted in error) and installed ACRN again. However, this didn't seem to make any difference. Though I saw after build that there was a .config file in build/hypervisor/ which had the default higher RAM values configured, instead of those which I'd set in hypervisor/build/.config. See the attached. Is the custom config somehow being ignored? Maybe this is not the main issue even if so...

My guess is that ACRN is not being loaded at all / the build is very broken, else I would expect this to at least print something out. Also wondered if using a serial console would help in debugging? Wasn't sure if this could provide greater insight into early boot failures.

Let me know if this looks like it may be an actual bug and I should log this on the issue tracker. At this point however I'm suspecting user error :o)

Regards,

Andrew

--
Andrew Back
http://abopen.com


Andrew Back
 

Hi Fuzhong,

Apologies, it was my error.

When I tried what you suggested, upon rebooting, Grub said that I needed
to load the kernel first, which reminded me that I'd seen the note at
the beginning of the Getting Started Guide about using "grub-2.04-7
bootloader with the following patch", but then not done anything about
this. Although the guide does go on to cover O/S installation and Grub
configuration in detail, without ever again explaining that you need to
build and install this specific version.

After installing the linked Grub version and reverting to the previous
40_custom configuration, I rebooted and could load ACRN and the Ubuntu SOS.

I should now be in a position to configure the application, but have a
few questions:

- There seemed to be a long delay after the loading ACRN message, before
Linux started

Presumably at this point there is output to the UART on the Front Panel
USB header? I've ordered the parts to make up a cable with the
appropriate JST connector.

- Why are the default platform and SOS RAM sizes for apl-up2 set to 16GB?

As I mentioned before, I'm not aware of any such board.

- hypervisor/build/.config vs. build/hypervisor/.config

After configuring the first of the above files to reduce RAM sizes, is
it normal to find the 2nd file in the build directory with the default
values? Perhaps it copies this in, but the settings placed in
hypervisor/build/.config actually take precedence?

- Could some version of Grub later than 2.04-7 be used?

Presumably later versions will incorporate the patch, but I'm guessing
you've just validated one or a small number of versions. This would be
useful to know if using another distro which has a later version, means
that I don't need to build this specific version from source each time.

- UP2 BIOS "Real Time Option"

This is disabled by default and sounds potentially useful, but I
couldn't find out anywhere what this does in practice.

Thanks for your help, it's appreciated.

Best,

Andrew

On 30/12/2020 01:25, Liu, Fuzhong wrote:
Hi Andrew
Could you please try multiboot instead of multiboot2?
multiboot2 /boot/acrn/acrn.bin -----> multiboot --quirk-modules-after-kernel /boot/acrn/acrn.32.out
If the issue is still there, please help to raise git issue and upload serial port log of ACRN.

Thanks!

BR.
Fuzhong

-----Original Message-----
From: acrn-users@lists.projectacrn.org <acrn-users@lists.projectacrn.org> On Behalf Of Andrew Back
Sent: Monday, December 28, 2020 8:15 PM
To: acrn-users@lists.projectacrn.org
Subject: [acrn-users] Failure to boot Industry scenario on UP2 Atom x7-E3950.

Hello,

Hardware is UP Squared P/N: UPS-APLX7-A20-0464 fitted with a 240GB mSATA drive.

Followed the getting started guide at:

https://projectacrn.github.io/latest/getting-started/rt_industry_ubuntu.html

Installing the UOS to the SATA drive and SOS to the 64GB eMMC. ACRN built with:

make all BOARD_FILE=misc/vm_configs/xmls/board-xmls/apl-up2.xml
SCENARIO_FILE=misc/vm_configs/xmls/config-xmls/apl-up2/industry.xml
RELEASE=0

Proceeded to build and install the kernel, and update Grub. Upon rebooting "loading ACRN..." is printed out and there is a pause for a few seconds, following which the system reboots. No other output at all.

I saw the note in the FAQ regarding memory and it looks as though the default configuration for both CONFIG_PLATFORM_RAM_SIZE and CONFIG_SOS_RAM_SIZE is 16GB, which seems odd, since AFAICT there is no
UP2 board available with more than 8GB fitted. In any case, I followed the instructions at:

https://projectacrn.github.io/latest/faq.html#how-do-i-configure-acrn-s-memory-size

Setting the aforementioned parameters both to 4GB and reducing CONFIG_UOS_RAM_SIZE to 1GB. Then rebuilt with 'make all RELEASE=0'
(specifying the XMLs this time resulted in error) and installed ACRN again. However, this didn't seem to make any difference. Though I saw after build that there was a .config file in build/hypervisor/ which had the default higher RAM values configured, instead of those which I'd set in hypervisor/build/.config. See the attached. Is the custom config somehow being ignored? Maybe this is not the main issue even if so...

My guess is that ACRN is not being loaded at all / the build is very broken, else I would expect this to at least print something out. Also wondered if using a serial console would help in debugging? Wasn't sure if this could provide greater insight into early boot failures.

Let me know if this looks like it may be an actual bug and I should log this on the issue tracker. At this point however I'm suspecting user error :o)

Regards,

Andrew

--
Andrew Back
http://abopen.com










--
Andrew Back
http://abopen.com