Topics

[acrn-dev] [acrn-users] ACRN on non-NUC platforms

Rajagopal Aravindan
 

Hello Victor,

While setting up configuration for my target machine, I am running into this error 

rajagopal@rajagopal-UX310UA:~/Workspace/ges/acrn-hypervisor/misc/acrn-config/target$ sudo python3 board_parser.py zenbook
Need CPUID version >= 20170122


FYI, PFA o/p of cat /proc/cpuinfo.
Is there a way I can run ACRN on this or need to give up on this machine ?

Any help/direction would be appreciated.

Thanks,
Rajagopal

On Tue, Oct 22, 2019 at 7:58 AM Victor Sun <victor.sun@...> wrote:

I think it should be OK.

Please refer "Board and VM configuration workflow" section in

    https://projectacrn.github.io/latest/tutorials/acrn_configuration_tool.html

to setup configuration for your board.

Any problems, please let me know.

BR,

Victor

On 10/21/2019 12:00 AM, Rajagopal Aravindan wrote:
Hello All,

I have a Core-i7(6500U) based laptop which supports h/w virtualization.

Wondering if ACRN can run on that or has any technical restrictions in running on platforms other than the ones in the supported h/w list ?

Any would help to get started on ACRN would be appreciated.

Thanks,
Rajagopal



Victor Sun
 

Your machine is fine.

Please replace your /usr/bin/cpuid to a higher version.

BR,

Victor


On 11/7/2019 3:16 AM, Rajagopal Aravindan wrote:
Hello Victor,

While setting up configuration for my target machine, I am running into this error 

rajagopal@rajagopal-UX310UA:~/Workspace/ges/acrn-hypervisor/misc/acrn-config/target$ sudo python3 board_parser.py zenbook
Need CPUID version >= 20170122


FYI, PFA o/p of cat /proc/cpuinfo.
Is there a way I can run ACRN on this or need to give up on this machine ?

Any help/direction would be appreciated.

Thanks,
Rajagopal

On Tue, Oct 22, 2019 at 7:58 AM Victor Sun <victor.sun@...> wrote:

I think it should be OK.

Please refer "Board and VM configuration workflow" section in

    https://projectacrn.github.io/latest/tutorials/acrn_configuration_tool.html

to setup configuration for your board.

Any problems, please let me know.

BR,

Victor

On 10/21/2019 12:00 AM, Rajagopal Aravindan wrote:
Hello All,

I have a Core-i7(6500U) based laptop which supports h/w virtualization.

Wondering if ACRN can run on that or has any technical restrictions in running on platforms other than the ones in the supported h/w list ?

Any would help to get started on ACRN would be appreciated.

Thanks,
Rajagopal



Rajagopal Aravindan
 

Hello Victor,

>>Your machine is fine.
>>Please replace your /usr/bin/cpuid to a higher version.
Tried running board_parser.py from inside 18.04.3 on the same machine and getting the below error ...

ubuntu@ubuntu:/mnt/home/rajagopal/Workspace/ges/acrn-hypervisor$ sudo python3 misc/acrn-config/target/board_parser.py zenbook
rdmsr: open: No such file or directory
Error:MSR 0x1ad not support in this platform!

I understand that a certain MSR is NOT present in my CPU.
Is that the end of road for ACRN on this machine ?

Where can I find information on why ACRN places such h/w constraints compared to other Type-1 hypervisors (Xen etc)?

Again, looking forward to your reply.

Thanks,
Rajagopal


On Thu, Nov 7, 2019 at 12:58 AM Victor Sun <victor.sun@...> wrote:

Your machine is fine.

Please replace your /usr/bin/cpuid to a higher version.

BR,

Victor


On 11/7/2019 3:16 AM, Rajagopal Aravindan wrote:
Hello Victor,

While setting up configuration for my target machine, I am running into this error 

rajagopal@rajagopal-UX310UA:~/Workspace/ges/acrn-hypervisor/misc/acrn-config/target$ sudo python3 board_parser.py zenbook
Need CPUID version >= 20170122


FYI, PFA o/p of cat /proc/cpuinfo.
Is there a way I can run ACRN on this or need to give up on this machine ?

Any help/direction would be appreciated.

Thanks,
Rajagopal

On Tue, Oct 22, 2019 at 7:58 AM Victor Sun <victor.sun@...> wrote:

I think it should be OK.

Please refer "Board and VM configuration workflow" section in

    https://projectacrn.github.io/latest/tutorials/acrn_configuration_tool.html

to setup configuration for your board.

Any problems, please let me know.

BR,

Victor

On 10/21/2019 12:00 AM, Rajagopal Aravindan wrote:
Hello All,

I have a Core-i7(6500U) based laptop which supports h/w virtualization.

Wondering if ACRN can run on that or has any technical restrictions in running on platforms other than the ones in the supported h/w list ?

Any would help to get started on ACRN would be appreciated.

Thanks,
Rajagopal



Victor Sun
 

0x1AD support is available for all latest desktop/mobile platform except some XEON processors. I guess you did not enable msr module by "modprobe msr" command.
I stated the requirement in README file as below:

OS requirement:
    Release:    Ubuntu 18.04+ or ClearLinux 30210+
    Tools:        cpuid, rdmsr, lspci, dmidecode
    kernel cmdline: "idle=nomwait intel_idle.max_cstate=0 intel_pstate=disable"

please make sure these tools is working before you execute board parser tool and vt-d is enabled in BIOS.

ACRN does not work well on some Xeon processor because the main purpose of ACRN is for IoT market, but we are still trying to fix some issues occurs on server platform. 

With current code, we have below limitations but we will fix them soon.

1. memory <= 16G
3. intel speedstep is enabled
3. ACPI CPU Pstate/Cstate table are enabled, and no mwait support when enforce ACPI idle driver.

please let me know your progress.
BR,
Victor

On 11/8/2019 3:08 AM, Rajagopal Aravindan wrote:
Hello Victor,

>>Your machine is fine.
>>Please replace your /usr/bin/cpuid to a higher version.
Tried running board_parser.py from inside 18.04.3 on the same machine and getting the below error ...

ubuntu@ubuntu:/mnt/home/rajagopal/Workspace/ges/acrn-hypervisor$ sudo python3 misc/acrn-config/target/board_parser.py zenbook
rdmsr: open: No such file or directory
Error:MSR 0x1ad not support in this platform!

I understand that a certain MSR is NOT present in my CPU.
Is that the end of road for ACRN on this machine ?

Where can I find information on why ACRN places such h/w constraints compared to other Type-1 hypervisors (Xen etc)?

Again, looking forward to your reply.

Thanks,
Rajagopal

On Thu, Nov 7, 2019 at 12:58 AM Victor Sun <victor.sun@...> wrote:

Your machine is fine.

Please replace your /usr/bin/cpuid to a higher version.

BR,

Victor


On 11/7/2019 3:16 AM, Rajagopal Aravindan wrote:
Hello Victor,

While setting up configuration for my target machine, I am running into this error 

rajagopal@rajagopal-UX310UA:~/Workspace/ges/acrn-hypervisor/misc/acrn-config/target$ sudo python3 board_parser.py zenbook
Need CPUID version >= 20170122


FYI, PFA o/p of cat /proc/cpuinfo.
Is there a way I can run ACRN on this or need to give up on this machine ?

Any help/direction would be appreciated.

Thanks,
Rajagopal

On Tue, Oct 22, 2019 at 7:58 AM Victor Sun <victor.sun@...> wrote:

I think it should be OK.

Please refer "Board and VM configuration workflow" section in

    https://projectacrn.github.io/latest/tutorials/acrn_configuration_tool.html

to setup configuration for your board.

Any problems, please let me know.

BR,

Victor

On 10/21/2019 12:00 AM, Rajagopal Aravindan wrote:
Hello All,

I have a Core-i7(6500U) based laptop which supports h/w virtualization.

Wondering if ACRN can run on that or has any technical restrictions in running on platforms other than the ones in the supported h/w list ?

Any would help to get started on ACRN would be appreciated.

Thanks,
Rajagopal