Re: failed to assign iommu device!

Kishore Kanala

Thanks for response.
I get same error even with QEMU 4.2.1
kishore@kishore-OMEN-by-HP-Laptop-15-dh0xxx:~$ /usr/bin/kvm-spice  --version
QEMU emulator version 4.2.1 (Debian 1:4.2-3ubuntu6.16)
Copyright (c) 2003-2019 Fabrice Bellard and the QEMU Project developers

kishore@kishore-OMEN-by-HP-Laptop-15-dh0xxx:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.4.0-72-generic root=UUID=27bc3288-2660-433b-93f2-be9ff3ed9e47 ro quiet splash vt.handoff=7

On Fri, May 7, 2021 at 8:01 AM Liu, Fuzhong <fuzhong.liu@...> wrote:

Hi Krishna Kishore

Could you please share your qemu version?

QEMU emulator version 4.2.0 is verified in this guide:


You should use qemu version >= 2.11.2 with below commit:

commit 0b250250b7e7298e0001faf76015da4b03b6b1b3

Author: Prasad Singamsetty <prasad.singamsetty@...>

Date:   Tue Nov 14 18:13:50 2017 -0500


    intel-iommu: Extend address width to 48 bits


    The current implementation of Intel IOMMU code only supports 39 bits

    iova address width. This patch provides a new parameter (x-aw-bits)

    for intel-iommu to extend its address width to 48 bits but keeping the

    default the same (39 bits). The reason for not changing the default

    is to avoid potential compatibility problems with live migration of

    intel-iommu enabled QEMU guest. The only valid values for 'x-aw-bits'

    parameter are 39 and 48.


    After enabling larger address width (48), we should be able to map

    larger iova addresses in the guest. For example, a QEMU guest that

    is configured with large memory ( >=1TB ). To check whether 48 bits

    aw is enabled, we can grep in the guest dmesg output with line:

    "DMAR: Host address width 48".


    Signed-off-by: Prasad Singamsetty <prasad.singamsety@...>

    Reviewed-by: Peter Xu <peterx@...>

    Reviewed-by: Michael S. Tsirkin <mst@...>

    Signed-off-by: Michael S. Tsirkin <mst@...>

    (cherry picked from commit 37f51384ae05bd50f83308339dbffa3e78404874)

    Signed-off-by: Michael Roth <mdroth@...>




From: acrn-users@... <acrn-users@...> On Behalf Of Liu, Fuzhong
Sent: Friday, May 7, 2021 6:47 AM
To: acrn-users@...
Subject: Re: [acrn-users] failed to assign iommu device!


Hi Krishna Kishore

Please try v2.0 for ACRN on qemu.

If still fail, please share cat /proc/cmdline of your host OS.







From: acrn-users@... <acrn-users@...> On Behalf Of Geoffroy Van Cutsem
Sent: Friday, May 7, 2021 5:05 AM
To: acrn-users@...
Subject: Re: [acrn-users] failed to assign iommu device!




Which version of ACRN are you using?


The error looks a bit different but be aware that the latest version of ACRN has a regression on QEMU:




From: acrn-users@... <acrn-users@...> On Behalf Of Krishna Kishore
Sent: Thursday, May 6, 2021 7:22 PM
To: acrn-users@...
Subject: [acrn-users] failed to assign iommu device!


[Edited Message Follows]

Can someone let me know how to overcome this problem? I am trying this

Loading ACRN hypervisor with SDC scenario ...
error: Can't get controller info..
Multiboot Bootloader: GRUB 2.02-2ubuntu8.21
ACRN Hypervisor
calibrate_tsc, tsc_khz=2591442
[4589978us][cpu=0][(null)][sev=2][seq=1]:HV version 2.5-unstable-2021-05-06 20:06:44-7c92ac425 DBG (daily tag:acrn-2021w18.5-180000p) sdc@qemu build by kishore, start time 4579269us
[4591202us][cpu=0][(null)][sev=2][seq=2]:API version 1.0
[4591568us][cpu=0][(null)][sev=2][seq=3]:Detect processor: Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
[4908926us][cpu=0][(null)][sev=1][seq=18]:PANIC: assign_vdev_pt_iommu_domain line: 296

[4909856us][cpu=0][(null)][sev=1][seq=19]:failed to assign iommu device!

Join to automatically receive all group messages.