Re: Problem with Industry Scenario on a NUC7i7DNH


Steve Osselton
 

Hi Yin,

I have a Samsung PCI SSD installed. Looking at it's capabilities I get:

Capabilities: [b0] MSI-X: Enable+ Count=33 Masked-

So looks like this is the problem. It it easy to up the number of supported MSIX tables?

Cheers Steve.

On Fri, 10 Jan 2020 at 05:00, Yin, Fengwei <fengwei.yin@...> wrote:
Hi Osselton,
It looks like there is one PCI device in your system which has more than
16 MSIX table.

Can you boot to native linux and dump the MSI table of each PCI devices
on your board?


Regards
Yin, Fengwei

On 2020/1/9 下午6:30, Steve Osselton wrote:
> Hi Liz,
>
> Was just following the instructions for example industry scenario for
> the 1.4 release, didn't build anything myself.
> Have tried again from scratch using latest updates for 1.5:
>
> 1 - Installed clear-32030-live-server.iso onto hard disk.
> 2 - Boot:
>
> # wget
> https://raw.githubusercontent.com/projectacrn/acrn-hypervisor/master/doc/getting-started/acrn_quick_setup.sh
> # chmod +x acrn_quick_setup.sh
> # ./acrn_quick_setup.sh -s 32030 -d -i
> # efibootmgr -c -l '\EFI\acrn\acrn.efi' -d /dev/sda -p 1 -L ACRN -u
> "uart=port@0x3f8"
>
> 3 - Reboot:
>
> Console output:
>
> ACRN Hypervisor
> calibrate_tsc, tsc_khz=2100000
> [11187656us][cpu=0][(null)][sev=2][seq=1]:HV version
> 1.5-unstable-2020-01-05 11:33:11- DBG (daily tag:) build by mockbuild,
> start time 11171478us
> [11201829us][cpu=0][(null)][sev=2][seq=2]:API version 1.0
> [11207570us][cpu=0][(null)][sev=2][seq=3]:Detect processor: Intel(R)
> Core(TM) i7-8650U CPU @ 1.90GHz
> [11218392us][cpu=0][(null)][sev=2][seq=4]:Assertion failed in file
> hw/pci.c,line 448 : fatal error
>
> Still failing ...
>
> Cheers Steve.
>
>
> On Thu, 9 Jan 2020 at 02:40, Liu, Fuzhong <fuzhong.liu@...
> <mailto:fuzhong.liu@...>> wrote:
>
>     Hi Steve____
>
>     Seem like, you are using very old codebase, can you try with v1.4
>     codebase first?____
>
>     If not; please share the commit id.____
>
>     Thanks!____
>
>     __ __
>
>     BR.____
>
>     Fuzhong____
>
>     __ __
>
>     *From:* acrn-users@...
>     <mailto:acrn-users@...>
>     <acrn-users@...
>     <mailto:acrn-users@...>> *On Behalf Of *Steve Osselton
>     *Sent:* Wednesday, January 8, 2020 11:34 PM
>     *To:* acrn-users@...
>     <mailto:acrn-users@...>
>     *Subject:* Re: [acrn-users] Problem with Industry Scenario on a
>     NUC7i7DNH____
>
>     __ __
>
>     Hi Liu,____
>
>     __ __
>
>     On inspection was running an old BIOS version, have upgraded to
>     latest version (DNi70067) and disabled hyper threading.____
>
>     Things are improved in that I now get diagnostics from the serial
>     port:____
>
>     __ __
>
>     ACRN Hypervisor
>     calibrate_tsc, tsc_khz=2100000
>     [11041475us][cpu=0][sev=2][seq=1]:HV version 1.4-unstable-2019-11-18
>     09:13:55- DBG (daily tag:) build by mockbuild, start time 11028016us
>     [11054921us][cpu=0][sev=2][seq=2]:API version 1.0
>     [11059914us][cpu=0][sev=2][seq=3]:Detect processor: Intel(R)
>     Core(TM) i7-8650U CPU @ 1.90GHz
>     [11069846us][cpu=0][sev=2][seq=4]:Assertion failed in file
>     hw/pci.c,line 250 : fatal error____
>
>     __ __
>
>     So still failing.____
>
>     __ __
>
>     Also as a comment, the BIOS settings descriptions, are badly out of
>     step with what you see from the latest visual BIOS.____
>
>     __ __
>
>     Cheers Steve.____
>
>     __ __
>
>     On Wed, 8 Jan 2020 at 13:46, Liu, Fuzhong <fuzhong.liu@...
>     <mailto:fuzhong.liu@...>> wrote:____
>
>         Hi Steve,____
>
>         Please disable Hyper thread in BIOS for workaround.____
>
>         This issue is fixed in  v1.5; will release soon.____
>
>         ____
>
>         BR.____
>
>         Fuzhong____
>
>         ____
>
>         *From:* acrn-users@...
>         <mailto:acrn-users@...>
>         <acrn-users@...
>         <mailto:acrn-users@...>> *On Behalf Of *Steve
>         Osselton
>         *Sent:* Wednesday, January 8, 2020 8:32 PM
>         *To:* acrn-users@...
>         <mailto:acrn-users@...>
>         *Subject:* [acrn-users] Problem with Industry Scenario on a
>         NUC7i7DNH____
>
>         ____
>
>         Hi,
>
>         Am essentially following the deployment instructions for the
>         ACRN industry scenario
>         using a NUC7i7DNH with a serial port connected.
>
>         https://projectacrn.github.io/latest/getting-started/rt_industry.html
>
>         Flashing clear-31670-live-server.iso worked fine. Then followed
>         the "Use the pre-installed industry ACRN hypervisor"
>         section and installed serial port support. Again this all worked
>         fine and looked good.
>
>         I then rebooted the NUC. At HDMI console get "Intel NUC" banner
>         with the following at top LHS of screen:
>
>         detected 8 processes, 8 enabled
>         current on process 0
>
>         And on serial port:
>
>         E0S0 S0
>
>         Not sure what has happened here. Am I missing something obvious ?
>
>         Thanks Steve ____
>
>
>     ____
>
>     __ __
>
>     -- ____
>
>     Engineering Director____
>
>     IOTech Systems Ltd.____
>
>     __
>
>
>
> --
> Engineering Director
> IOTech Systems Ltd.
>





--
Engineering Director
IOTech Systems Ltd.

Join acrn-users@lists.projectacrn.org to automatically receive all group messages.