Re: Try to follow the Getting Started


Hello Geoffrey,

thanks for your help. Since your replied I re installed the system a couple of times (min. 10x) because of errors.

The first thing is that I downloaded "clear-26200-installer" and the swupd verify not worked for 26200. I changed to version 29030 that was recommended.

The second wired thing was that after install of all packages the reboot sometimes not worked "Failed to talk to init daemon".

The next error was that I got errors belong to rcx  (lines 987,1056) in the make procdure of the acrn-hypervisor.

"arch/x86/guest/instr_emul.c: In function ‘emulate_instruction’:
arch/x86/guest/instr_emul.c:1056:7: error: ‘rcx’ may be used uninitialized in this function [-Werror=maybe-uninitialized]
 1056 |   rcx = rcx - 1;
      |   ~~~~^~~~~~~~~
arch/x86/guest/instr_emul.c:987:11: note: ‘rcx’ was declared here
  987 |  uint64_t rcx, rdi, rsi, rflags;
      |           ^~~

That worked sometimes and sometimes not.

The last error that occurred was that I had no space for updating the "clr-boot-manager", I found out that I had too much bootoptions in the system. 

I'm stucking in getting the thing working.

I don't know if you could help me or if I destroyed my whole system.



Am 24.04.19 um 16:13 schrieb Geoffroy Van Cutsem:

Hi Thomas,


Welcome to the ACRN community!!


Your kernel command-line is most likely incorrect, change root=/dev/mmcblk0p1 to root=/dev/mmcblk0p3 (the first partition is typically the EFI System Partition (ESP), the root filesystem being put on the 3rd partition in Clear Linux). Can you try to update it and let us know if that gets you further?




From: acrn-users@... [mailto:acrn-users@...] On Behalf Of walzert
Sent: Wednesday, April 24, 2019 4:01 PM
To: acrn-users@...
Subject: [acrn-users] Try to follow the Getting Started


Hello together,

a short introduction I'm a research assistant at Reutlingen University. I work with the LF projects zephyr and AGL. My universtiy will hopefully join the LF soon.  I'm working on getting AGL running on UP² with ACRN as hypervisor.  We plan to distribute our AGL builds to different boards at university and we want to do that with ACRN.

I followed the documentation on the latest version. I changed the things according the UP² getting started.

Everything worked until I tried to start the "acrn hypervisor" in grub then it hangs on

"fb: switching to inteldrmfb from EFI VGA"



Below I have my changed lines for Up²:

sudo mount /dev/mmcblk0p1 /mnt

sudo mkdir /mnt/EFI/acrn

sudo cp /usr/lib/acrn/acrn.efi /mnt/EFI/acrn/

efibootmgr -c -l "\EFI\acrn\acrn.efi" -d /dev/mmcblk0 -p 1 \

    -L "ACRN Hypervisor" \

    -u "bootloader=\EFI\org.clearlinux\bootloaderx64.efi uart=bdf@0:18.1 vuart=ttyS1@irq5"


sudo vi /mnt/loader/entries/acrn.conf

title The ACRN Service OS

linux   /EFI/org.clearlinux/kernel-org.Clearlinux.iot-lts2018-sos.4.19.34-45

options pci_devices_ignore=(0:18:1) console=tty0 console=ttyS2 i915.nuclear_pageflip=1 root=/dev/mmcblk0p1 rw rootwait ignore_loglevel no_timer_check consoleblank=0 i915.tsd_init=7 i915.tsd_delay=2000 i915.avail_planes_per_pipe=0x01010F i915.domain_plane_owners=0x011111110000 i915.enable_guc_loading=0 i915.enable_guc_submission=0 i915.enable_preemption=1 i915.context_priority_mode=2 i915.enable_gvt=1 i915.enable_initial_modeset=1 i915.enable_guc=0 hvlog=2M@0x1FE00000

sudo clr-boot-manager set-timeout 20

sudo clr-boot-manager update



Thank you  and greetings



Thomas Walzer
Reutlingen Research Institute (RRI)
Raum 20-022
Hochschule Reutlingen
Alteburgstraße 150
72762 Reutlingen
Tel. +49 (0) 7121 / 271 – 4061
Tel. +49 (0) 7121 / 271 - 4094


Thomas Walzer
Reutlingen Research Institute (RRI)
Raum 20-022
Hochschule Reutlingen
Alteburgstraße 150
72762 Reutlingen
Tel. +49 (0) 7121 / 271 – 4061
Tel. +49 (0) 7121 / 271 - 4094

Join { to automatically receive all group messages.