Re: Post-launched user VM with preempt-RT kernel doesn't start


c.susen@...
 

Hi again,

I managed to add a PCIe card with serial ports to my ACRN host and am now able to use the ACRN shell to get further information on what is going wrong. I hope that the following information makes it easier for you to maybe help me with the setup.

ACRN shell output when using launch_uos_id1.sh -> user VM starts succesfully
[53863044us][cpu=0][vm1:vcpu0][sev=3][seq=100]:VMX ctrl 0x482 not fully enabled: request 0x92220088 but get 0x9621e1fa
[53874398us][cpu=0][vm1:vcpu0][sev=3][seq=101]:VMX ctrl 0x48b not fully enabled: request 0x41004ab but get 0x1004ab
[59499335us][cpu=0][vm1:vcpu0][sev=3][seq=104]:vlapic: Start Secondary VCPU1 for VM[1]...
[59507819us][cpu=1][vm1:vcpu1][sev=3][seq=105]:VMX ctrl 0x482 not fully enabled: request 0x92220088 but get 0x9621e1fa
[59519253us][cpu=1][vm1:vcpu1][sev=3][seq=106]:VMX ctrl 0x48b not fully enabled: request 0x41004ab but get 0x1004ab

ACRN shell output when using launch_uos_id2.sh -> user VM does not start
[186233178us][cpu=5][vm0:vcpu5][sev=1][seq=114]:vpci_assign_pcidev 1:0.0 not support FLR or not support PM reset
[186244017us][cpu=5][vm0:vcpu5][sev=3][seq=115]:pci_vdev_update_vbar_base reprogram PCI:01:00.0 BAR4 to addr:0x4000, which is out of mmio window[0x80000000 - 0xe0000000] or not aligned with size: 0x4000
[186286873us][cpu=2][vm2:vcpu0][sev=3][seq=116]:VMX ctrl 0x482 not fully enabled: request 0x92220088 but get 0x9621e1fa
[186298343us][cpu=2][vm2:vcpu0][sev=3][seq=117]:VMX ctrl 0x48b not fully enabled: request 0x41004ab but get 0x1004ab
[193720869us][cpu=2][vm2:vcpu0][sev=3][seq=121]:vlapic: Start Secondary VCPU1 for VM[2]...
[193729429us][cpu=3][vm2:vcpu1][sev=3][seq=122]:VMX ctrl 0x482 not fully enabled: request 0x92220088 but get 0x9621e1fa
[193740972us][cpu=3][vm2:vcpu1][sev=3][seq=123]:VMX ctrl 0x48b not fully enabled: request 0x41004ab but get 0x1004ab
[194318797us][cpu=5][vm0:vcpu5][sev=3][seq=171]:ret=-1 hypercall=0x80000023 failed in vmcall_vmexit_handler
[194329142us][cpu=5][vm0:vcpu5][sev=3][seq=172]:ret=-1 hypercall=0x80000023 failed in vmcall_vmexit_handler
[194339567us][cpu=5][vm0:vcpu5][sev=3][seq=173]:ret=-1 hypercall=0x80000023 failed in vmcall_vmexit_handler

Output when using vm_console 2
Loading Linux 5.10.52-rt47 ...
Loading initial ramdisk ...

I would really appreciate if someone could help me with that! Thanks in advance!

Best regards,
Christoph

Join acrn-users@lists.projectacrn.org to automatically receive all group messages.