Re: gpio ist not seen in the acrn hypervisor in the whl 10


Jianjie Lin
 

Hi Geoffory,

 

Actually, we also identified the same problem; namely, the gpio controller is not detected even in the native Linux.

We also tried to contact the manufacture, but it isn't easy to get the contact.

We see the tutorial from the acrn website, the acrn hypervisor offers the virto-gpio, it seems that you can manage to detect or download the gpio controller.

I know, it is not the problem of acrn

 

Thanks

Jianjie LIN

 

Von: acrn-users@... <acrn-users@...> Im Auftrag von Geoffroy Van Cutsem
Gesendet: Donnerstag, 28. Oktober 2021 14:50
An: acrn-users@...
Betreff: Re: [acrn-users] gpio ist not seen in the acrn hypervisor in the whl 10

 

It seems like the basic GPIO controller is not even detected, which can be caused by a driver that’s missing. Have you ever been able to use the GPIO interface on that board using a native Linux (no ACRN)?

 

If so, we could start by comparing the kernel configs (at least the ones pertaining to GPIO) and see if we should enable some options in the acrn-kernel for you.

 

Geoffroy

 

From: acrn-users@... <acrn-users@...> On Behalf Of Jianjie Lin
Sent: Thursday, October 28, 2021 1:27 pm
To: acrn-users@...
Subject: Re: [acrn-users] gpio ist not seen in the acrn hypervisor in the whl 10

 

Hi Geoffory,

In my case, ls /sys/bus/gpio/devices is empty

I use the tutorial here,

https://www.ics.com/blog/gpio-programming-using-sysfs-interface

https://unix.stackexchange.com/questions/485324/how-to-identify-gpio-pin-numbers-is-gpio-driver-loaded

 

But it did not work out for me

Thanks,

Jianjie Lin

 

Von: acrn-users@... <acrn-users@...> Im Auftrag von Geoffroy Van Cutsem
Gesendet: Donnerstag, 28. Oktober 2021 13:05
An: acrn-users@...
Betreff: Re: [acrn-users] gpio ist not seen in the acrn hypervisor in the whl 10

 

Hi Jianjie,

 

There isn’t much useful info in the log that you attached in your previous email. Can you expand a bit on how you have tried to use this? Do you see the any GPIO controller (e.g.: ls /sys/bus/gpio/devices)

 

Thanks,

Geoffroy

 

From: acrn-users@... <acrn-users@...> On Behalf Of Jianjie Lin
Sent: Thursday, October 28, 2021 10:29 am
To: acrn-users@...
Subject: Re: [acrn-users] gpio ist not seen in the acrn hypervisor in the whl 10

 

Hi Fuzhong,

 

Thank you very much for your reply.

In cannot see gpio pins in sor and HV?

I tried with serval methods, but apparently, it did not work out. We try to use this gpio pin to control the motor as an automotive application.

I attached the boot log.

 

If you need to any information about the whiskey lake, I am pleasure to offer those information.

Thank you .

Best,

Jianjie Lin

 

Von: acrn-users@... <acrn-users@...> Im Auftrag von Liu, Fuzhong
Gesendet: Mittwoch, 27. Oktober 2021 09:36
An: acrn-users@...
Betreff: Re: [acrn-users] gpio ist not seen in the acrn hypervisor in the whl 10

 

Hi Jianjie

Not see the gpio pins in sos or HV? 

 

Could you please share full HV boot log about your issue?

 

Thanks!

 

BR.

Fuzhong

From: acrn-users@... <acrn-users@...> On Behalf Of Geoffroy Van Cutsem
Sent: Tuesday, October 26, 2021 10:29 PM
To: acrn-users@...; Xie, Nanlin <nanlin.xie@...>
Subject: Re: [acrn-users] gpio ist not seen in the acrn hypervisor in the whl 10

 

Hi Jianjie,

 

I do not have any experience with the GPIO subsystem I’m afraid, @Xie, Nanlin, can you ask someone on the engineering team to help look at this?

 

Thanks,

Geoffroy

 

From: acrn-users@... <acrn-users@...> On Behalf Of Jianjie Lin
Sent: Thursday, October 21, 2021 3:35 pm
To: acrn-users@...
Subject: [acrn-users] gpio ist not seen in the acrn hypervisor in the whl 10

 

Hi Acrn community,

 

After we successfully deployed the acrn hypervisor in the whiskey board 10, we found we could not see the gpio pins inside the acrn hypervisor, which apparently should be included.

Do you know the reason?

 

Thank you

Best,

Jianjie Lin

 

 

 

Join acrn-users@lists.projectacrn.org to automatically receive all group messages.