ACRN Networking problem


Jianjie Lin
 

Hi Acrn community,

 

I just faced another problem in terms of networking.

I follow the tutorial from the document by using

Enable network sharing for the User VM

In the Ubuntu Service VM, enable network sharing for the User VM:

$ sudo systemctl enable systemd-networkd
$ sudo systemctl start systemd-networkd

and the ifconfig I got is:

 

acrn-br0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

        inet6 fe80::502a:fbff:fe20:e829  prefixlen 64  scopeid 0x20<link>

        ether 52:2a:fb:20:e8:29  txqueuelen 1000  (Ethernet)

        RX packets 259  bytes 28200 (28.2 KB)

        RX errors 0  dropped 3  overruns 0  frame 0

        TX packets 35  bytes 8894 (8.8 KB)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

enp1s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500

        ether b0:41:6f:03:c6:1a  txqueuelen 1000  (Ethernet)

        RX packets 0  bytes 0 (0.0 B)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 0  bytes 0 (0.0 B)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

        device memory 0xa1200000-a121ffff  

 

enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

        ether b0:41:6f:03:c6:1b  txqueuelen 1000  (Ethernet)

        RX packets 259  bytes 31826 (31.8 KB)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 35  bytes 8894 (8.8 KB)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

        device memory 0xa1100000-a111ffff  

 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536

        inet 127.0.0.1  netmask 255.0.0.0

        inet6 ::1  prefixlen 128  scopeid 0x10<host>

        loop  txqueuelen 1000  (Local Loopback)

        RX packets 119  bytes 9331 (9.3 KB)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 119  bytes 9331 (9.3 KB)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

tap0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500

        ether 9e:80:1e:99:4f:82  txqueuelen 1000  (Ethernet)

        RX packets 0  bytes 0 (0.0 B)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 0  bytes 0 (0.0 B)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500

        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255

        ether 52:54:00:0b:09:e0  txqueuelen 1000  (Ethernet)

        RX packets 0  bytes 0 (0.0 B)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 0  bytes 0 (0.0 B)

 

After that, I do not have internet access anymore.

Do you have any suggestions on how to fix the problem?

Moreover, I test with the console version, and it also has no internet.

For your information, I have attached my launch file.

 

 

Mit freundlichen Grüßen / Kind regards
--------------------------------------------------------

Jianjie Lin

 

E-Mail: Jianjie.Lin@...

Mobil:  +49-176-8443-6814

Join acrn-users@lists.projectacrn.org to automatically receive all group messages.