ACRN hypervisor message: VMX ctrl 0x48b not fully enabled: request 0x18b but get 0x8b


Geoffroy Van Cutsem
 

Hi folks,

When booting ACRN on my KBL NUC (NUC7i7DNHE), I see the following messages on the console:
ACRN Hypervisor
calibrate_tsc, tsc_khz=2100000
[12273476us][cpu=0][sev=2][seq=9]:HV version 0.3-unstable-2018-10-08 12:58:18-eebccac2 DBG (daily tag:acrn-2018w41.1-140000p) build by root, start time 12268466us
[12289298us][cpu=0][sev=2][seq=10]:API version 1.0
[12294405us][cpu=0][sev=2][seq=11]:Detect processor: Intel(R) Core(TM) i7-8650U CPU @ 1.90GHz
[12303669us][cpu=0][sev=2][seq=12]:hardware support HV
[12309831us][cpu=0][sev=3][seq=13]:mmu_modify_or_del, invalid parameters!

[12330813us][cpu=0][sev=3][seq=14]:System S3/S5 is NOT supported.
[12337424us][cpu=0][sev=2][seq=32]:Start VM0
[12341873us][cpu=0][sev=3][seq=33]:VMX ctrl 0x48b not fully enabled: request 0x18b but get 0x8b

ACRN:\>[20011982us][cpu=0][sev=3][seq=6438]:vlapic: Start Secondary VCPU1 for VM[0]...
[20019793us][cpu=1][sev=3][seq=6439]:VMX ctrl 0x48b not fully enabled: request 0x18b but get 0x8b

[20038219us][cpu=0][sev=3][seq=6441]:vlapic: Start Secondary VCPU2 for VM[0]...
[20046046us][cpu=2][sev=3][seq=6442]:VMX ctrl 0x48b not fully enabled: request 0x18b but get 0x8b
<snip>

The system seems to be working fine except for the boot time that is quite high, I have no idea yet what is causing the slow boot time and I'm therefore exploring many of the warnings/errors I see in the system so any help to make me understand this one above would be appreciated :-)

Thanks,
Geoffroy

Join acrn-users@lists.projectacrn.org to automatically receive all group messages.