|
Re: [PATCH v2] tools: acrntrace: Add ring buffer mode
We don't want to complicate the debug tools too much. I remember we can already set the size of the log file. That is enough.
Thx Eddie
We don't want to complicate the debug tools too much. I remember we can already set the size of the log file. That is enough.
Thx Eddie
|
By
Eddie Dong
·
#10432
·
|
|
Re: [PATCH] hv: treewide: fix Macro redefine, usage -- and operation violations
Acked-by: Eddie Dong <eddie.dong@...>
This seems to be better to be "d--".
Acked-by: Eddie Dong <eddie.dong@...>
This seems to be better to be "d--".
|
By
Eddie Dong
·
#10431
·
|
|
Re: [PATCH v2 1/3] HV: Add the emulation of CPUID with 0x16 leaf
The vcpuid base on these assumption:
(1) if we don't plan to support this feature, we could filter it.
(2) if the leaf greater than the limit (base or enternal), we should return the value in the
The vcpuid base on these assumption:
(1) if we don't plan to support this feature, we could filter it.
(2) if the leaf greater than the limit (base or enternal), we should return the value in the
|
By
Li, Fei1
·
#10430
·
|
|
Re: [PATCH 5/6] DM USB: xHCI: change flow of creation of virtual USB device
I think it should be re-connection instead of disconnection, right?
Currently, the native S3 will disable the vbus for all xHCI ports and
re-drive during S3 resume. This behavior cause native USB
I think it should be re-connection instead of disconnection, right?
Currently, the native S3 will disable the vbus for all xHCI ports and
re-drive during S3 resume. This behavior cause native USB
|
By
Yu Wang
·
#10429
·
|
|
Re: [PATCH v2] tools:acrn-crashlog: Document of configuration file
I don't see a PR for this in GitHub. Can it be submitted there for review?
-- david
I don't see a PR for this in GitHub. Can it be submitted there for review?
-- david
|
By
Kinder, David B
·
#10428
·
|
|
Re: [PATCH v2] tools: acrntrace: Add ring buffer mode
By
Geoffroy Van Cutsem
·
#10427
·
|
|
Re: [PATCH 4/6] DM USB: xHCI: refine port assignment logic
For "= 0" and "< 0", please define some macros...
For "= 0" and "< 0", please define some macros...
|
By
Yu Wang
·
#10426
·
|
|
Re: [PATCH 3/6] DM USB: introduce struct usb_native_devinfo
dificulties?
Then usb_dev_info is not useful now? Should we clear it?
This new structure is confused to me. There has already one structure
struct usb_dev which included native usb device
dificulties?
Then usb_dev_info is not useful now? Should we clear it?
This new structure is confused to me. There has already one structure
struct usb_dev which included native usb device
|
By
Yu Wang
·
#10425
·
|
|
[PATCH v2] tools: acrntrace: Add ring buffer mode
When running longevity test and capturing acrntrace, generated acrntrace
files sizes are too big.
Sometimes we don't care very old trace. This patch adds ring buffer
mode, fixes acrntrace file size
When running longevity test and capturing acrntrace, generated acrntrace
files sizes are too big.
Sometimes we don't care very old trace. This patch adds ring buffer
mode, fixes acrntrace file size
|
By
Zhipeng Gong <zhipeng.gong@...>
·
#10424
·
|
|
Re: [PATCH 2/6] DM USB: xHCI: refine xHCI PORTSC Register related functions
Can we remove intr variable? Is hasn't changed in this function and pass
to pci_xhci_port_disconnect directly..
Ditto.
What is mean of intr? From this patch, it almost useless..
Let's keep
Can we remove intr variable? Is hasn't changed in this function and pass
to pci_xhci_port_disconnect directly..
Ditto.
What is mean of intr? From this patch, it almost useless..
Let's keep
|
By
Yu Wang
·
#10423
·
|
|
Re: [PATCH v2] tools:acrn-crashlog: Document of configuration file
Thanks!
@David, can you take a look at this when you get a chance?
Thanks,
Geoffroy
Thanks!
@David, can you take a look at this when you get a chance?
Thanks,
Geoffroy
|
By
Geoffroy Van Cutsem
·
#10422
·
|
|
Re: [PATCH v3] tools:acrn-crashlog: Document of configuration file
By
Geoffroy Van Cutsem
·
#10421
·
|
|
Re: [PATCH] HV: hv_main: Add #ifdef HV_DEBUG before debug specific code
#ifdef
Got it.
By
Kaige Fu
·
#10420
·
|
|
Re: [PATCH] hv: treewide: fix Macro redefine, usage -- and operation violations
junjunshan1 <junjun.shan@...> writes:
Some general conventions about commit logs:
1. Each line should be no more than 80 characters. Break the
paragraph if it is longer than that.
junjunshan1 <junjun.shan@...> writes:
Some general conventions about commit logs:
1. Each line should be no more than 80 characters. Break the
paragraph if it is longer than that.
|
By
Junjie Mao
·
#10419
·
|
|
[PATCH] hv: treewide: fix Macro redefine, usage -- and operation violations
MISARC has requirements about Marco redefinition, usage of ++ or -- and assignment operator in boolean expression.
This patch is used to solve these violations.
The modifications are summarized as
MISARC has requirements about Marco redefinition, usage of ++ or -- and assignment operator in boolean expression.
This patch is used to solve these violations.
The modifications are summarized as
|
By
Junjun Shan
·
#10418
·
|
|
Re: [PATCH v3] HV: fix "missing for discarded return value" for vm related api
OK, this is my fault. I am not aware the code here has been changed to prepare_vm() recently.
I will fix it in my next version.
The purpose here is want to return a failure.
Is it better to return a
OK, this is my fault. I am not aware the code here has been changed to prepare_vm() recently.
I will fix it in my next version.
The purpose here is want to return a failure.
Is it better to return a
|
By
Victor Sun
·
#10417
·
|
|
Re: [PATCH v2 1/3] HV: Add the emulation of CPUID with 0x16 leaf
By
Zhao, Yakui
·
#10416
·
|
|
Re: [PATCH] HV: hv_main: Add #ifdef HV_DEBUG before debug specific code
#ifdef
In general we should do in different patch for bug fix. But this one is simple for those compile option --- this looks like MISRAC patches, we can do together to save
In general we should do in different patch for bug fix. But this one is simple for those compile option --- this looks like MISRAC patches, we can do together to save
|
By
Eddie Dong
·
#10415
·
|
|
Re: [PATCH v3] HV: fix "missing for discarded return value" for vm related api
By
Eddie Dong
·
#10414
·
|
|
Re: [PATCH] HV: hv_main: Add #ifdef HV_DEBUG before debug specific code
#ifdef
Absolutely, we should do it. This should be done in another patch, right?
>
>
>
Absolutely, we should do it. This should be done in another patch, right?
>
>
>
|
By
Kaige Fu
·
#10413
·
|